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Your press kit is a way of 
promoting the product or services 
your project can provide, in 
a visually appealing way for 
media, investors, and potential 
clients to learn about all that 
you have to offer. In the past, 
one would have to hire someone 
to coordinate the creation of 
a press kit, but in this section 
you will learn how to make one 
yourself, that not only can be 
used as a traditional press kit 
(that is printed and handed out) 
as well as an electronic press 
kit (you guessed it...a digital 
file to distribute!). Often times 
press kits will be formatted 
with an emphasis on credentials 
before any of your products or 
services are shown. We’re going 
to flip that and showcase it while 
building supporting evidence 
around it.



before we begin

In order to create a press kit that can be used both traditionally 
and digitally, we will be creating an interactive PDF using 
Adobe InDesign. We’ll also be using Adobe Photoshop for any 
graphics that we plan on using in the press kit. Any version of 
these programs from CS3 onwards should be suitable. If these 
programs are not available to you, Adobe allows for limited 
trials that allows for the full functionality of their programs 
to be used. Finally, it would be a good idea to review this whole 
section and prepare all your written content on a word processor 
before putting together your press kit. Having your edited and 
finalized text ready beforehand will help for layout purposes. We 
will know exactly how much space will be required for text and 
can design accordingly. 

Assuming your content is ready to go, and you have Adobe 
InDesign and Photoshop open, we can set up our parameters. 
We will be using Photoshop to create page designs, and we 
will be using InDesign to put together the press kit. Follow the 
instructions below to setup your press kit dimensions and your 
page dimensions on InDesign and Photoshop, respectively. Both 
settings are inputted after you go to File and then Create New 
Document.
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Adobe InDesign Adobe Photoshop

Number of Pages: 12
Facing Pages: Checked
Page Width: 33p0
Page Height: 51p0
Margins: 0 (All)
Bleed: 9p0 (All)

Page Width: 5.5 inches
Page Height: 8.5 inches
Resolution: 200
Colour Mode: CMYK

https://creative.adobe.com/products/creative-cloud
https://creative.adobe.com/products/creative-cloud
https://creative.adobe.com/products/creative-cloud


before we begin
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Now that we have our pages in front of us, we should be able to 
fill it with content. Leave your first and last page on the InDesign 
document for your front and back covers and use Photoshop to 
create them. 

Once you’ve created a design, save it as JPG or PNG and then drag 
that file into InDesign. This will leave just the content pages to 
focus on. Remember to have your branding and social channels 
open in this process as you want to make sure it is consistent 
with every other piece of material you put out. Note down the 
exact colours used in your project and use Photoshop to create a 
page background. Make sure it fits your brand colours and that 
it is really simple, as this is the background to your press kit. It 
shouldn’t be too detailed as it may take away from the content 
that is placed on top of it. Once done, simply save it as a JPG or 
PNG and drag and drop it in to all of your content pages.

If you are not well versed in the world of Adobe InDesign, breathe 
easy. There is a wide selection of great tutorials to get you up 
to speed on all its features. TastyTuts provides an excellent 
beginner series on YouTube. 

Quick Tip: good function makes for good design. Preparing a well 
formatted press kit will go a long way in the overall look and feel 
of your press kit.

From this point onwards, it is assumed that your front and back 
cover pages are finalized and placed in your InDesign document. 
Furthermore, your background page design is also applied to all 
of the content pages. Review the following three examples of 
layouts that others have used.
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https://www.youtube.com/watch?v=iHDy_nEvgd4&feature=youtu.be
https://www.youtube.com/watch?v=iHDy_nEvgd4&feature=youtu.be


section 01 - Project profile
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This is the part of your press kit where you show people who you 
are, what you stand for, where you are coming from, and why your 
product/service matters. Your profile should be engaging and 
concise, and accurately show the personality of your brand. The 
purpose of this section is to give a brief but engaging overview of 
your project’s profile, purpose, and context.

It is key to include your mission statement, vision, and objectives 
in this section. Having done so will provide that clear and concise 
information that your reader is looking for.

Before you highlight those areas, make sure to weave your story 
through this section as it emphasizes why your project exists and 
is needed right at the start. Being able to answer this confidently, 
while letting your reader know what your project is all about, is 
a great strategy. In doing this, you create a tone that a reader can 
connect to. The following two examples illustrate the difference 
it makes when you weave a story into your profile.

Bad Example: Skype’s mission is to make sure you can see and 
talk to people you care about.

Good Example: Skype’s mission is to be the fabric of real-time 
communication on the web.



section 02 - portfolio
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Getting straight into your work is a great approach to the flow 
of your press kit. After explaining your story to the reader, 
displaying what you have worked on is the next logical step. The 
reader will be able to answer the questions of who you are and 
what you have done up until this point. These are two very big 
points that identifying early will allow your project to place more 
emphasis on the effectiveness of your work.

As your project can include various forms of media including 
images, video, and audio - you want to be able to highlight your 
best work and incorporate it interactively into your press kit. 
Before we break down what to do with each type of file, remember 
to only highlight 3 to 5 pieces of work and treat them as case 
studies. Include a key image, a brief write up of what you have 
done, and a series of thumbnails or a link to see more of the work 
online. If your line of work does not produce much in the form 
of visuals, feel free to take some photos that support each of the 
projects you have worked on to include beside your write up and 
link it to a particular project. With that, let’s take a look at how to 
handle different types of media.

Video - Adobe InDesign allows users to embed videos into their 
posts. It is recommended that you do not do this, but rather 
hyperlink a version of your video on YouTube. This will keep your 
press kit file relatively low for both print and sending digitally. 
Having a telling image or frame from your video placed on your 
portfolio, and hyperlinking it is an effective solution. To do so, 
click on the image you import into your document. Now in the 
top menu go to Window > Interactivity > Hyperlinks. With your 
image selected, you can use the dialog box in the window you just 
opened to format your hyperlink. You can also use this feature on 
text as well.



section 02 - portfolio
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Image - A lot easier than video, you can click and drag your image 
straight into your document. Format it so it fits your layout and 
make sure it is the best visual you can use to represent that 
particular project. You can also import your image via File > Place.

Audio - Audio can also be embedded into your document but we 
recommend using images for the same reason stated for video. 
You want to be able to provide a document at a minimal size to 
avoid people ignoring your press kit due to size. However if your 
audio file is small, you can go to the top menu and hit File > Place 
by locating your sound clip. From there, go to the top menu again 
and hit Window > Interactive > Media to format the file.



section 03 - statistics
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Show the statistics, percentages, ratios and trends related to your 
project. People love to be able to measure things with numbers 
and facts. Having statistics or not won’t necessarily make or 
break your press kit, many press kits exist that don’t provide 
any statistics. But it does add a level of professionalism to your 
press kit and helps to legitimize your business. Seeing stats helps 
people to have confidence in your product or service. From a flow 
perspective, having identified who you are and what you have 
done, your statistics speak as tangible results related to your 
project. It is your measured effectiveness so if this section is 
valuable to your project, there are a variety of different statistics 
you can present in your press kit, including:

Product/Service Statistics 

+ Previous years sales

+ Number of people reached by your service

+ The percentage of your clients who experienced improvements 
due to your service.

Market Statistics 

+ Stats relevant to your target demographic/market

+ Social Media Statistics 

+ Number of followers

+ Number of hits/page views on your website/blog



section 04 - Testimonials/press

Having shown the tangible results to your project, the next important 
piece is what people are saying about your project and the people 
behind the project itself. Highlighting the benefits of how it is to 
work with you will be key for potential customers considering what 
a working relationship with you may look like. Let your supporters 
do the talking. Word of mouth is the best kind of promotion available 
because its free, and other people are doing it for you. Keep gathering 
testimonials along every step of your journey, as this is should be an 
ongoing activity. Every time you have a successful encounter with 
a client ask them to provide you with some feedback or a quote you 
can use for promotion. Target high-profile clients or supporters to 
lend you some words.

To provide further evidence of your projects success, include your 
awards. This helps the reader identify where you have already 
been recognized. A quick note about awards, if they don’t know you 
exist, you won’t get the award. Since awards in these cases are often 
nomination based, or requires you to nominate yourself, if you don’t 
actively search and apply for these awards, you won’t win them.

Finally, recent articles by press are key in showing that people are 
already paying attention to what you are currently doing. If you don’t 
have any press coverage yet, actively seek coverage. Get familiar 
with how to create a press release and send them out to local media 
to cover your story, and make sure to get copies of any audio, video, 
or text (articles) that are created when they cover your story. Follow 
up with any media outlets who cover your story, and provide them 
with an opportunity to do a follow up story, later on down the road. 
Keep them in the loop on any updates, but don’t bombard them with 
the small details. Regarding your press kit, include these articles and 
hyperlink out to them so your reader can access this content easily. 
Including the latest articles will be an added touch as it shows the 
momentum you currently have.
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section 05 - contact info
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This section wraps up your press kit. After you have presented 
all your sections, this one identifies all the different ways the 
reader can contact you. We recommend that this section is the 
last page of your press kit (before the back cover). Including your 
name, email address, social media links, and physical location 
should allow for enough points of contact. Remember to use the 
hyperlink tool in Adobe InDesign so the reader can click on each 
of the points of contact and be directed to the right channels.



section checklist

additional resources

+ Create Electronic Press Kit (for artists w/o InDesign)

+ Extensive Press Kit Guidelines

+ Research Your Own Market

+ Great Portfolio Tips for Designers
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set up your document

complete project profile section

complete portfolio section

complete statistics and/or press sections

continue contact info section

http://artistecard.com/epk
http://vicfringeartists.webs.com/apps/blog/entries/show/10704239-tutorial-3-press-kits-press-releases-and-social-media
http://homebusiness.about.com/od/Setting-Up-Your-Business/a/do-your-own-market-research.htm
http://www.creativebloq.com/create-perfect-design-portfolio-111153


With a press kit completed, 
you can now promote your 
project. Digitally, you can 

distribute it to however many 
people you’d like without 

having to worry about print 
costs. You may even want to 
send it to parties you intend 

on pitching to prior to the 
actual pitch. The next section 

will help you piece together 
an effective pitch for once 

you get there.



our sources

+ Branded Conference 2014
+ Brand Channel
+ Business Insider
+ Forbes
+ HootSuite
+ Internet Live Stats

+ Investopedia
+ Pink City
+ Splash Effect
+ Search Engine Land
+ TastyTuts
+ US Small Businesses

avnu partners

funded by

This toolkit was created in partnership with Branded, 
and their Youth Marketing Conference. To find out more 
about Branded, visit their website at brandedto.com




